1. BENVENUTO SU CONSOLE TRIBE

    Benvenuto, stai navigando nella nostra community come ospite

    Avere un account su Console Tribe ti permetterà di creare e partecipare alle discussioni e al mercatino, organizzare tornei e partite online, iniziare conversazioni personali con gli altri giocatori del forum e di utilizzare tutte le funzioni di questo sito.

    Registra il tuo account in meno di 5 secondi, se vuoi puoi sfruttare i login social via Facebook, Google Plus o Twitter.

Apache, mi aiutate a settare una cosa?

Discussione in 'O.T. - Off Topic' iniziata da -=]}»ASii«{[=-, 3 Settembre 2005.

  1. -=]}»ASii«{[=-

    -=]}»ASii«{[=- Tribe Member

    Registrato:
    10 Aprile 2005
    Messaggi:
    4.312
    "Mi Piace" ricevuti:
    0
    Punteggio:
    190
    Località:
    Pescara
    Xbox Live Tag:
    Radishasii
    ho un server apache abbastanza recente corretamente installato, compreso mysql, insomma tutto quello che serve ad esempio per fare partire un forum in locale.

    adesso ho per mano un form/scr ipt che serve per creare degli account per un server game che risiede sul mio pc, con questo form uno crea automaticamente degli account per giocare sul mio server.
    i requisiti per questo form sono

    quando testo la pagina mi esce una pagina di errore immagino che sia dovuto al requisito elencato prima: Server Configured to Use POST/GET Functions
    non me ne intendo tantissimo di apache e server (neanche tanto di php se non il minimo), mi chiedevo come configuro o controllo se il server è configurato per usare il la funzione POST/GET? non so se è indicativa la cosa ma ad esempio il forum che ho sul mio pc funziona perfettamente, il messaggio di errore è:
  2. gigyz

    gigyz Tribe Member

    Registrato:
    14 Luglio 2005
    Messaggi:
    219
    "Mi Piace" ricevuti:
    0
    Punteggio:
    16
    penso che la cosa riguarda il PHP, copi e incollo da php.ini:
    Codice:
     - register_globals = Off         [Security, Performance]
    ;     Global variables are no longer registered for input data (POST, GET, cookies,
    ;     environment and other server variables).  Instead of using $foo, you must use
    ;     you can use $_REQUEST["foo"] (includes any variable that arrives through the
    ;     request, namely, POST, GET and cookie variables), or use one of the specific
    ;     $_GET["foo"], $_POST["foo"], $_COOKIE["foo"] or $_FILES["foo"], depending
    ;     on where the input originates.  Also, you can look at the
    ;     import_request_variables() function.
    ;     Note that register_globals is going to be depracated (i.e., turned off by
    ;     default) in the next version of PHP, because it often leads to security bugs.
    ;     Read http://php.net/manual/en/security.registerglobals.php for further
    ;     information.
    quindi direi che devi settare nel php.ini register_globals= On anche se non è il max della sicurezza.
  3. -=]}»ASii«{[=-

    -=]}»ASii«{[=- Tribe Member

    Registrato:
    10 Aprile 2005
    Messaggi:
    4.312
    "Mi Piace" ricevuti:
    0
    Punteggio:
    190
    Località:
    Pescara
    Xbox Live Tag:
    Radishasii
    già, alla fine cmq ho cambiato form che aggirava quel problema quindi in effetti quel settaggio per il momento lo lascio off.

    grazie cmq, quando mi si ripesenterà il problema e non trovo alternative saprò dove andare ;)

Condividi questa Pagina